Results 1 to 10 of 10

Thread: charge light/alternator... wtf

  1. #1
    Veteran NIZLAH's Avatar
    Join Date
    Dec 2008
    Name
    Niz
    State
    QLD
    Location
    South~Slide Briz
    Country
    Australia
    Posts
    1,077

    Default charge light/alternator... wtf


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Hey just having a few issues with my daily (toyota seca 4afe) was driving about on the w.e and all was good...
    then the charge light came on, so I was all like fuck gota make it home before the battery dies.. (thinking that the alternator had stopped working)
    I checked the belts and for any loose connections/wires but it all seems sweet.. so took it for a drive the following day and the charge light wasn't showing.. this leaving me going "wtf"??
    Anyways I drove it to work today and all was good until I made my way home and it came on again, it proceeded to stay on, then go off, come on then flick on/off etc all the way home....
    Basically I'm a little un-sure what would cause this and I don't really trust it...
    If the alternator went? wouldn't the charge light stay on continually ?

    can anyone shed some light?

    Cheers
    Niz,
    Last edited by NIZLAH; 21st January 2009 at 09:13 PM.
    ------------------>>>Need something welded locally??? Hit me up, I may just be able to help<<<------------------

    BENT MECHANIX - Garage 20:

  • #2
    Veteran blair's Avatar
    Join Date
    Dec 2008
    Name
    Blair
    State
    QLD
    Location
    Sheldon
    Country
    Australia
    Posts
    3,047

    Default

    mines been on for over 6 months... its still swoit

  • #3
    Moderator Frak's Avatar
    Join Date
    Dec 2008
    Name
    Jamie
    State
    SA
    Location
    Adelaide
    Country
    Australia
    Posts
    1,324

    Default

    Not all alternator failures will bring the light on.

  • #4
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    691

    Default

    usually when a charge light acts as you have described, the alternator is nearing the end of its life. When the alternator is spinning (engine running), the light has to turn off for the alternator to charge correctly, if it doesnt, it will either no charge at all, or incorrect voltage.

    I would get it rebuilt, or grab another one from the wreckers, there should be a few there.

    Hope this helps!

  • #5
    Veteran NIZLAH's Avatar
    Join Date
    Dec 2008
    Name
    Niz
    State
    QLD
    Location
    South~Slide Briz
    Country
    Australia
    Posts
    1,077

    Default

    Quote Originally Posted by blair View Post
    mines been on for over 6 months... its still swoit
    lol, I was hoping that it may just be some glitch like this...
    ------------------>>>Need something welded locally??? Hit me up, I may just be able to help<<<------------------

    BENT MECHANIX - Garage 20:

  • #6
    Veteran NIZLAH's Avatar
    Join Date
    Dec 2008
    Name
    Niz
    State
    QLD
    Location
    South~Slide Briz
    Country
    Australia
    Posts
    1,077

    Default

    Quote Originally Posted by Frak View Post
    Not all alternator failures will bring the light on.
    any ideas on what else good cause this behavior?
    ------------------>>>Need something welded locally??? Hit me up, I may just be able to help<<<------------------

    BENT MECHANIX - Garage 20:

  • #7
    Veteran NIZLAH's Avatar
    Join Date
    Dec 2008
    Name
    Niz
    State
    QLD
    Location
    South~Slide Briz
    Country
    Australia
    Posts
    1,077

    Default

    Quote Originally Posted by Sprinter86 View Post
    usually when a charge light acts as you have described, the alternator is nearing the end of its life. When the alternator is spinning (engine running), the light has to turn off for the alternator to charge correctly, if it doesnt, it will either no charge at all, or incorrect voltage.

    I would get it rebuilt, or grab another one from the wreckers, there should be a few there.

    Hope this helps!
    cheers man, I was going to take it to get rebuilt on the w.e but then thought it was all good as it wasn't lighting up when I test drove it..
    My last experience with an alternator shitting its self was in my 86 a few years ago, and the light just stayed on, thats what made me think it could possibly be something else... looks like its getting a refresh this w.e then...
    ------------------>>>Need something welded locally??? Hit me up, I may just be able to help<<<------------------

    BENT MECHANIX - Garage 20:

  • #8
    Senior Member stylz's Avatar
    Join Date
    Dec 2008
    Name
    Art
    State
    VIC
    Location
    Melb
    Country
    Australia
    Posts
    420

    Default

    check your earth cable from the motor, mines been playing up for ages and i finally checked it out the weekend. turn out the earth cable from the motor to chasis was pop riveted on and it would jump around and get loose. fixed that all up and i havnt had the problem yet

  • #9
    Veteran Nikkojoe's Avatar
    Join Date
    Dec 2008
    Name
    Tom
    State
    WA
    Location
    Perth
    Country
    Australia
    Posts
    2,260

    Default

    Going on and off is probably pointing to a faulty regulator or brushes. When the charge light stays on, check the voltage at the battery with the car running (it should be greater than 13V, optimum between 13.5-14.5V).

    Other then that, could just be a faulty connection (either earth or the plug on the alternator).
    1983 AE86 ADM rust spec goodness track car build - end of the road
    1984 AE86 Silver ADM mk2 daily build - SOLD
    1984 AE86 ADM granny car daily now 4AGZE - SOLD
    1983 AE86 ADM Engine Conversion Slut - SOLD
    2002 IS200 6spd - new daily in progress
    1986 AE86 JDM GT-Apex Levin Notchback ready to roll......

  • #10
    Veteran NIZLAH's Avatar
    Join Date
    Dec 2008
    Name
    Niz
    State
    QLD
    Location
    South~Slide Briz
    Country
    Australia
    Posts
    1,077

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Problem fixed (I think) haven't driven it enough yet but seems all good.. funny enough I went and got a new exchange alternator today and realised it is exactly the fucking same as the one I had sitting here off my JDM 16v lol (even could make out 'seca' written on it from previous reco a few years ago) .. ended up chucking the one off the 16v in and putting the nice shiny new one aside for my 20v swap..
    ------------------>>>Need something welded locally??? Hit me up, I may just be able to help<<<------------------

    BENT MECHANIX - Garage 20:

  • Similar Threads

    1. Charge Light always on
      By Kwan in forum Technical - Questions
      Replies: 2
      Last Post: 12th April 2011, 09:22 PM
    2. AE86 alternator charge light.
      By 86TRD in forum Technical - Questions
      Replies: 2
      Last Post: 26th November 2010, 12:21 AM
    3. charge light wire
      By deanoo in forum Technical - Questions
      Replies: 0
      Last Post: 16th June 2007, 01:29 PM
    4. Charge Light on DASH
      By AE71_Rolla in forum Technical - Questions
      Replies: 6
      Last Post: 8th June 2007, 05:21 PM
    5. Charge Light
      By marvis in forum Technical - Questions
      Replies: 9
      Last Post: 18th November 2005, 01:53 AM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •