Page 8 of 10 FirstFirst 1 2 3 4 5 6 7 8 9 10 LastLast
Results 71 to 80 of 94

Thread: 7AGTE 20v TE71 Sedan Track Car build

  1. #71
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    697

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Found the problem, wastegate pretty flogged leaking boost past the valve guide. back on the rollers soon and hopefully go for a proper power run!

  • #72
    Veteran pen15's Avatar
    Join Date
    Dec 2008
    Name
    Mathew
    State
    NSW
    Location
    Sutho Shire
    Country
    Australia
    Posts
    1,859

    Default

    yeah thats a bad #### i cant wait to see numbers what injectoirs are you running?
    the dyno pull to 300rwkw

    BT20v is making 300rwkw like i said i would without nitrous so now its time for some spray and see if she will run a 10s or less

  • #73
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    697

    Default

    cheers mate!, um running sard 800cc 2j injectors.

    we snapped the dowel in the inlet cam in the middle of a power run, due to 'OBX' camgears being shit, should of googled the brand before, notorious for manufacturing errors.

    TODA Cam Gears on the way now.

    For some unknown reason we really arn't getting much more power than 185kw, i figure we should be seeing at least 100kw more than that.

    im sure it will be something silly that was overlooked, hopefully can sort it out.

    http://s237.photobucket.com/user/jeb...ddf44.mp4.html


    split a water hose at the end of this dyno run haha
    Last edited by Sprinter86; 19th June 2013 at 05:23 PM.

  • #74
    Veteran
    Join Date
    Dec 2008
    Name
    John
    State
    TAS
    Location
    Hobart
    Country
    Australia
    Posts
    2,200

    Default

    7AG motors seem notorious for under performing due to cam timing issues...id be starting with that

  • #75
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    697

    Default

    ^^^ best thing ive heard in ages! i really do hope that is the case here

  • #76
    Member B-Lugg's Avatar
    Join Date
    Apr 2012
    Name
    Ben
    State
    QLD
    Location
    Gold Coast
    Country
    Gold Coast, Queensland, Australia
    Posts
    34

    Default

    Oi, you, update.

  • #77
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    697

    Default

    I really have been lazy with the updating!

    I have basically gone back to drawing board with the engine and starting again. with a heap of help from Stu at cave hill engines!

    Basically i have changed pistons to toyota 4agze items.
    Teflon coated the skirts and ceramic coated the crowns.
    Using a crank girdle and moroso baffled sump this time also.
    Head is receiving a full port and chamber job complimented with 1mm oversize supertech valves.

    Dont have many pictures yet but assembly starts next week.

    heres a few pics of the port and chamber work:

    Inlet match ported to black throttle manifold:



    De-shrouded smoothed and polished chambers:



    exhaust port:



    I will take lots of pictures as we re assemble the engine, she will be back!

  • #78
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    697

    Default

    And here we go!




  • #79
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    697

    Default




  • #80
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    697

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN

  • Page 8 of 10 FirstFirst 1 2 3 4 5 6 7 8 9 10 LastLast

    Similar Threads

    1. Just JDM Imports Track Car Build
      By 44GTE in forum AE86 Owners Forums
      Replies: 18
      Last Post: 24th July 2012, 11:00 AM
    2. Dave's KE70 budget track car build
      By lildavo in forum KE70 / AE71 Owners Forums
      Replies: 6
      Last Post: 16th April 2012, 12:43 AM
    3. KE70 Drift/Track Car Build.
      By luke641 in forum KE70 / AE71 Owners Forums
      Replies: 38
      Last Post: 19th March 2012, 06:50 PM
    4. ST or BT 20v for 7AGTE Build? Keep vvt?
      By PRIMRK in forum Technical - Questions
      Replies: 10
      Last Post: 13th September 2010, 07:03 PM
    5. SRE70 Track Car Build up
      By chrizer in forum KE70 / AE71 Owners Forums
      Replies: 37
      Last Post: 2nd June 2008, 01:50 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •