Results 1 to 5 of 5

Thread: engine runs rich and won't rev

  1. #1
    Senior Member --Redwork--'s Avatar
    Join Date
    Jan 2009
    Name
    Jason
    State
    QLD
    Location
    Nundah
    Country
    Australia
    Posts
    954

    Default engine runs rich and won't rev


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Just finished my conversion today.
    Wired it to JAP spec as it has JDM ecu and car started first try but won't rev and poors out fuel smoke.

    This is my first convertion so I'm not 100% sure I have all the sensors needed to run the engine properly....
    Definatly missing a Knock sensor.

    Theres also HEAPS of extra plugs that looks a right mess.

    What could cause it to run so bad.?
    On te plus side it sounds tuff as..

  • #2
    Senior Member Sprinter86's Avatar
    Join Date
    Dec 2008
    Name
    Nathan
    State
    VIC
    Location
    Lilydale
    Country
    Australia
    Posts
    691

    Default

    first thing i would do is ask the ecu.

    if the ecu is the cause, (ie. 'limp' mode), it will tell you why.

    you need to connect a test light across two pins in the ecu, i have forgotten which pins exactly they are, although a 2 minute googe search will no doubt tell you exactly which ones.

    thats what i would do after the usual basic checks anyway!

  • #3
    Senior Member --Redwork--'s Avatar
    Join Date
    Jan 2009
    Name
    Jason
    State
    QLD
    Location
    Nundah
    Country
    Australia
    Posts
    954

    Default

    Ahh true... I never thought of that...
    To used to after market ecu's.
    Pitty I don't have a test light...
    First thing on the list for tomorow...!!

  • #4
    Veteran Clinton's Avatar
    Join Date
    Dec 2008
    Name
    Clinton
    State
    NSW
    Location
    Tweed Heads
    Country
    Australia
    Posts
    3,048

    Default

    you could make one if you wanted to dick around.

    FTP.
    Quote Originally Posted by svenmate View Post
    I love how all the SA boys get on board
    Quote Originally Posted by Konakid View Post
    im driving out there with new hydro setup
    Quote Originally Posted by myke90 View Post
    haha i have the exact same picture from when i got my sportmaxx lol.
    Quote Originally Posted by Richard View Post
    whats with the drift rings? i know they are just a novelty but do they represent or signify anything?

  • #5
    Senior Member --Redwork--'s Avatar
    Join Date
    Jan 2009
    Name
    Jason
    State
    QLD
    Location
    Nundah
    Country
    Australia
    Posts
    954

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Yeah think I'll wait till tomorow and spend like 5 bucks to buy one..
    spent WAY to much time in my garage the last couple of weeks to be stuffing about making a tool that I can get down the street for next to nothing..

  • Similar Threads

    1. Replies: 24
      Last Post: 19th June 2011, 04:59 PM
    2. Engine Runs rough while under 2000rpm under load.
      By Kwan in forum Technical - Questions
      Replies: 3
      Last Post: 17th February 2011, 09:05 PM
    3. Car won't rev past 4000rpm - JDM bigport
      By Course_Out in forum Technical - Questions
      Replies: 11
      Last Post: 21st November 2009, 02:22 AM
    4. Engine won't rev over 4000rpm
      By LeviNafey in forum Technical - Questions
      Replies: 28
      Last Post: 7th August 2007, 10:16 PM
    5. WON'T REV
      By Whip in forum Technical - Questions
      Replies: 10
      Last Post: 26th May 2005, 05:49 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •