Results 1 to 6 of 6

Thread: Ke70 4kc piston dead?

  1. #1
    Bad Email Address
    Join Date
    Dec 2008
    Posts
    572

    Default Ke70 4kc piston dead?


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Hey fellas,

    I think the last piston near the firewall is dead. The car drives a bit rough, but no overly. It doesnt drive like it has dropped a piston but when idling i can pull the spark plug ignitor off and the car wont change any idle sounds exact same.

    Ive tried changing spark plugs, lead but no improvement.

    Any ideas what it could be, or has it just dropped a piston?

    Cheer

  • #2
    Senior Member
    Join Date
    Dec 2008
    Name
    Dan
    State
    Vic
    Location
    Western Subs
    Country
    Australia
    Posts
    405

    Default

    headgasket?
    cracked bore?
    rings gone?
    . h i t o r i k o .

  • #3
    Senior Member DearmanKE's Avatar
    Join Date
    Dec 2008
    Name
    Alex
    State
    SA
    Location
    Northfield
    Country
    Australia
    Posts
    131

    Default

    when the car is idling hold that plug end of that lead next to the body,

    if its sparking it should arc and earth to the body,
    Formerly known as grape_moosha

  • #4
    Bad Email Address
    Join Date
    Dec 2008
    Posts
    572

    Default

    though when driving iam certain its on all 4 pistons..
    Last edited by AE86R; 1st April 2009 at 12:43 AM.

  • #5
    Veteran Clinton's Avatar
    Join Date
    Dec 2008
    Name
    Clinton
    State
    NSW
    Location
    Tweed Heads
    Country
    Australia
    Posts
    3,048

    Default

    pull the rocker cover off and see if it any push rods have fallen off the rocker arm. i remember that happened to mine once and i was running on 2 cylinders for like 5 or so hours then teddy from ke70.com and a few other guys fixed it on a cruise with eye feeler guages and cleaned the metal out of the oil from the rocker cover being belted with straw...

    apparently it happens a fair bit with 4ks too.

    FTP.
    Quote Originally Posted by svenmate View Post
    I love how all the SA boys get on board
    Quote Originally Posted by Konakid View Post
    im driving out there with new hydro setup
    Quote Originally Posted by myke90 View Post
    haha i have the exact same picture from when i got my sportmaxx lol.
    Quote Originally Posted by Richard View Post
    whats with the drift rings? i know they are just a novelty but do they represent or signify anything?

  • #6
    Veteran
    Join Date
    Dec 2008
    Name
    Dave
    State
    QLD
    Location
    Brisbane
    Country
    Australia
    Posts
    2,666

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    i think saying that a piston is "Dead" is a bit.....agricultural...

    you prolly just have either a stuffed dizzy cap/spark plug or something.

    unless you have actually blown the rings then youll prolly know about it more than a rough idle.

    list of things to do!

    -check spark of each lead against the block (as previously mentioned)

    then when you get a spark from all of them

    -take out your spark plugs and test them against the block and make sure they are sparking. give them a rough up with a wire brush

    if all your spark is working you have to dig deaper.

    and nothing digs deap like a compression test!

    that will tell you everything.

    then report back with compression results!

    ok....GO!

  • Similar Threads

    1. Wanted: Dead 4AGE alternators & starters, Dead T50's
      By Golberg in forum Cars or Parts Wanted
      Replies: 8
      Last Post: 7th January 2011, 08:49 AM
    2. wrecking xx ke70 5spd 4kc
      By wide s13 in forum Car Parts For Sale
      Replies: 6
      Last Post: 27th June 2010, 05:10 PM
    3. Replies: 5
      Last Post: 17th April 2009, 12:47 AM
    4. ke70 4kc prob
      By Gus Baby in forum Technical - Questions
      Replies: 5
      Last Post: 12th February 2009, 10:00 AM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •