Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: RIM Issue

  1. #1
    Bad Email Address
    Join Date
    Apr 2009
    Posts
    14

    Default RIM Issue


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Went to the local tire shop today to have my tire check as the tyre has been losing its pressure. The store has mentioned that the reason is due to the rim (15x8 -15, no buckle or damage) is too old and too much offset thus it does not hold the pressure of the tire anymore.

    Has anyone experienced the same issue and where can I get the rim repaired or what is the issue??

  • #2
    Senior Member --Redwork--'s Avatar
    Join Date
    Jan 2009
    Name
    Jason
    State
    QLD
    Location
    Nundah
    Country
    Australia
    Posts
    954

    Default

    Is it a 2 or three peice rim...

    The join could just need to be resealed with silicon if its a multi peive rim....

    If the wheel is straight with no damage it sould hold air..
    Offset has NO bearing on it at all...

    Of its a single peice rim then. either the tyre is damaged or the vavle is stuffed.

  • #3
    Member cable tie's Avatar
    Join Date
    Jan 2009
    Name
    shaun
    State
    nsw
    Location
    avalon
    Country
    australia
    Posts
    90

    Default

    pics of rims.... i'm in the market for some 15x8-15's if u wana sell them
    second to a hammer a cable tie can fix anything!!!!

  • #4
    Bad Email Address
    Join Date
    Apr 2009
    Posts
    14

    Default

    its a work equip 3pc rim and the store has tried to put some stuff (some beards thingy) to strength the joint between the rim and tire, but pressure still leak along the wall. valve has been changed too. btw, its a brand new tire.

    where can I buy metal valve???

  • #5
    Member cable tie's Avatar
    Join Date
    Jan 2009
    Name
    shaun
    State
    nsw
    Location
    avalon
    Country
    australia
    Posts
    90

    Default

    where u located???

    new tyre?? what size??

    how old the rims>>?? u used them b 4>?? maybe the edge is slightly rollled out if there used?? or if u had them repaired there may be a slight blemish u can't seen on the in side of the rim where air is leaking out???

    if the rim needs fixed talk to aluminium engenieering in brokvale, and the boys a bob jane broovale always fit tuff tyres and stretch on mine and they also have metal valves for free but not sure if thats close to you??

    if it is u gota come meet me i wana chack ur 86 and we can do a palmy run
    second to a hammer a cable tie can fix anything!!!!

  • #6
    Bad Email Address
    Join Date
    Apr 2009
    Posts
    14

    Default

    im located in ryde area...

    btw .. i got it wrong .. its long champ... not equip

    tire size is 195/50/15 the rims are old ... its from a mate.. its work well with the old doggy tire before putting the new tire on it. sign...

    where abt the place in brokvale ... open on sat?? whats the damage $$ ??

    any idea ... what's the issue or the tire is stuffed??
    Last edited by fat20v; 19th April 2009 at 12:31 AM.

  • #7
    Senior Member --Redwork--'s Avatar
    Join Date
    Jan 2009
    Name
    Jason
    State
    QLD
    Location
    Nundah
    Country
    Australia
    Posts
    954

    Default

    How long has the tyre been on the rim.???
    Have you driven on it yet.??

    The front runners on my drag car kept goin flat in about a day and half after gettin them fitted...
    Once I drove on them they were fine...
    Stayed up for ages...

    If you had a tyre on there before and it was all right I'd be questioning the new tyre you put on... Did they replace the vavle when it was fitted.?
    I've had a vavle play up on me befor...

    I ended up just pumping the tyre up to about 50 psi the sticking a pen it there to let the pressure out then pumped it up again and was golden.. Was most likely just a bit of shit in it...

  • #8
    Bad Email Address
    Join Date
    Apr 2009
    Posts
    14

    Default

    have the new tire tire for a few days... the loss of pressure happens the very next day after fitted... went back today ... and tested and changed the valve again... but pressure still leaks from the gap between the tire and the rim... they just claimed that its a old rims ... and old rims have this issue... gees..... i think they have no idea...

  • #9
    Senior Member --Redwork--'s Avatar
    Join Date
    Jan 2009
    Name
    Jason
    State
    QLD
    Location
    Nundah
    Country
    Australia
    Posts
    954

    Default

    Yeah.... definatly sounds like it....

    Go some wher else..

  • #10
    Member cable tie's Avatar
    Join Date
    Jan 2009
    Name
    shaun
    State
    nsw
    Location
    avalon
    Country
    australia
    Posts
    90

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    oh like these

    place in brooky in on pittwater road, call them they'll direct u 02 9905 0481

    they fitted my tires no probs and can put in new valve free wit $10 to fit tire prob??

    otherwise if is bent and needs re rounding call alli engineering 99396319 anywhere from 60 to 180 with ploish depending how bent it is...

    if u give up i'll buy them off you
    second to a hammer a cable tie can fix anything!!!!

  • Page 1 of 2 1 2 LastLast

    Similar Threads

    1. bent rim
      By whatcamber in forum Technical - Questions
      Replies: 17
      Last Post: 15th February 2011, 03:46 PM
    2. rim widths
      By kurtis in forum General Topics (No Technical Questions)
      Replies: 14
      Last Post: 3rd February 2007, 10:36 PM
    3. do u like to rim?
      By dori_86 in forum Technical - Questions
      Replies: 13
      Last Post: 16th November 2006, 10:26 PM
    4. Rim Width
      By Rallystanza in forum General Topics (No Technical Questions)
      Replies: 1
      Last Post: 27th April 2005, 11:17 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •