Results 1 to 7 of 7

Thread: high idle, please help

  1. #1
    Senior Member
    Join Date
    Dec 2008
    Name
    callum
    State
    qld
    Location
    tully
    Country
    australia
    Posts
    353

    Default high idle, please help


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    ok. i just did a turbo conversion and all is good. after a few days of driving normally i took my mate for a spririted drive and when we came back the idle of the car was really high, i let it sit for a few hours then started it again and yea still idls high.
    any suggestions as to whats causing it?
    cheers.

  • #2
    Veteran ae86's Avatar
    Join Date
    Dec 2008
    Name
    Dave
    State
    VIC
    Location
    Western Suburbs
    Country
    Australia
    Posts
    3,766

    Default

    happens to my car but mines jus 4ag n/a, if its same problem as mine check idle screw or ur throttle cable could be sticking somewhere like mine

  • #3
    Senior Member
    Join Date
    Dec 2008
    Name
    callum
    State
    qld
    Location
    tully
    Country
    australia
    Posts
    353

    Default

    ill check that as soon as some ones home to help me open the bonnet. but would it just happen all of a sudden like that? i held the throttle wheel thing down as far as it would go so i dont think its the throttle cabel sticking.

  • #4
    Bad Email Address
    Join Date
    Dec 2008
    Posts
    111

    Default

    my car had same problem and could never figure it out, sent it to get tuned and the guy fixed it though the ecu, possible fuel mixture when idle?

  • #5
    Veteran ae86's Avatar
    Join Date
    Dec 2008
    Name
    Dave
    State
    VIC
    Location
    Western Suburbs
    Country
    Australia
    Posts
    3,766

    Default

    im not sure champ like i got the same problem, today i had a long drive on like a 30 degree day, on idle goes up to 1500, then if i tap it up to 2 then it will idle on 600

  • #6
    Gone
    Join Date
    Dec 2008
    Name
    Joel
    State
    NSW
    Location
    Picton
    Country
    Australia
    Posts
    4,042

    Default

    Try some WD40 on the throttle linkage and the cam and give it a gut full of carbi cleaner, my mini and dato use to do that it's a pain , I think just with all the extra heat and metal expansion something mayb catching. Worth a try

  • #7
    Banned
    Join Date
    Nov 2008
    Posts
    421

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    have a look at all your hoses on your inlet vaccume or mayb inlet gasket is gone

  • Similar Threads

    1. 16v small port high idle
      By KAYE70 in forum Technical - Questions
      Replies: 13
      Last Post: 20th May 2012, 06:23 PM
    2. *SOLVED* - Blacktop 20V High Idle
      By 70XIN in forum Technical - Questions
      Replies: 22
      Last Post: 24th October 2010, 08:23 PM
    3. High idle - the endless saga
      By Golberg in forum Technical - Questions
      Replies: 16
      Last Post: 4th May 2009, 08:19 PM
    4. 4age HIGH idle
      By stylz in forum Technical - Questions
      Replies: 1
      Last Post: 27th July 2008, 08:39 PM
    5. help with high idle
      By DriftPlease in forum Technical - Questions
      Replies: 7
      Last Post: 14th January 2007, 06:11 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •