Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Clutch Fail :(

  1. #1
    Member
    Join Date
    Feb 2009
    Name
    Justin
    State
    NSW
    Location
    North Sydney
    Country
    Australia
    Posts
    62

    Default Clutch Fail :(


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Hey Guys

    I was heading out on Saturday, got to the lights around the corner and the car kept trying to stall on me so gave it a few revs as this usally happens right after cold start stupid microwreck. Didn't help and could then smell slight burnt clutch as this stage I was WTF clutch pedal went really soft and jsut wouldnt work, so I manged to drive back home round the corner in second.

    Now I have a problem, the clutch master resivour is empty, so I refilled it and pumped the pedal a bit hoping to see a spilt in the line that would explain my resivour emptying its self, but the pedal never builds pressure its constant easy to push like when ur breaks fail

    I can feel alot of fluid int he heat wrap around the bottom of the clutch line where it bolts to the slave

    Usally I coudl repair this myslef, but all my tools are in NZ

    So was wondering if anyone on here that lives on the lower northshore could help me one evening, I am happy to drive to you, I have skills to mash the T50 without clutch or could reccomend a workshop to go to as I need my car fixed

    I live very close to crows nest, if thats any help don't really want to have to far

    I'm guessin it either a leak in the line, or the master or the slave have shat them selves, being over 20ty years old I'm not suprised

    Any help would be massivly appreachiated as I really want to get my car going,

    I am will to pay $$$$$$ thats no problem

    If you could reply here or just give me a yell on 0449739766

    Perferable near mine, but if worst comes to worst I will hire a towie

    Cheers

    Justin
    Last edited by Justin Holden; 27th April 2009 at 09:14 AM.

  • #2
    Scammer, DO NOT BUY FROM ME!
    Join Date
    Jan 2009
    Name
    Richard
    State
    NSW
    Location
    2220
    Country
    Australia
    Posts
    228

    Default

    Man I had the same problem about a month ago, worse mine shat itself far from home but I managed to make it to the nearest petrol station and buy myself some clutch fluid...I had to top up the fluids every 3-5mins

    Ended up replacing the master and the slave

    Hope you fix yours with no dramas.

    Regards,
    Richard

    EDIT: Those of you from the Shire, my car shat itself at the start of Tom Uglies Bridge on the single lane going north...farken itch-bay...
    Last edited by PeakingDuck; 27th April 2009 at 10:45 AM.

  • #3
    Member
    Join Date
    Feb 2009
    Name
    Justin
    State
    NSW
    Location
    North Sydney
    Country
    Australia
    Posts
    62

    Default

    Quote Originally Posted by PeakingDuck View Post
    Man I had the same problem about a month ago, worse mine shat itself far from home but I managed to make it to the nearest petrol station and buy myself some clutch fluid...I had to top up the fluids every 3-5mins

    Ended up replacing the master and the slave

    Hope you fix yours with no dramas.

    Regards,
    Richard
    Yeah I filled mine up, and pumped the pedal but its not getting any firmer and its not spraying out anywhere which makes me wonder if theres more to it than just a split line

    If anyone can help me it would be awesome as I have no tools at all over here

    Or can recomend me a workshop close by it would be mega

  • #4
    Gone
    Join Date
    Dec 2008
    Name
    Joel
    State
    NSW
    Location
    Picton
    Country
    Australia
    Posts
    4,042

    Default

    Quote Originally Posted by PeakingDuck View Post
    Man I had the same problem about a month ago, worse mine shat itself far from home but I managed to make it to the nearest petrol station and buy myself some clutch fluid...I had to top up the fluids every 3-5mins

    Ended up replacing the master and the slave

    Hope you fix yours with no dramas.

    Regards,
    Richard

    EDIT: Those of you from the Shire, my car shat itself at the start of Tom Uglies Bridge on the single lane going north...farken itch-bay...
    hahah u freaken lost hard their!! imagine u were prolly hated by about 50 ppl all at once right then..

    Just a question only because u guys didnt mention it.. but after toping up the clutch fluid did u bleed the system from the clutch slave?? if u dont then u will never get rid of the spongy or dead pedal.
    When was the last time u check the clutch resivour? it could have had a slow leak and o'nce the fluid gets low enough it will just suck air into the system

  • #5
    Scammer, DO NOT BUY FROM ME!
    Join Date
    Jan 2009
    Name
    Richard
    State
    NSW
    Location
    2220
    Country
    Australia
    Posts
    228

    Default

    Quote Originally Posted by sundee86 View Post
    hahah u freaken lost hard their!! imagine u were prolly hated by about 50 ppl all at once right then..
    x100 I forgot to mention the main bridge going north was shut down for maintenance, this was on a thursday night after late night shopping....LMFAO
    Last edited by PeakingDuck; 28th April 2009 at 12:13 PM.

  • #6
    Scammer, DO NOT BUY FROM ME!
    Join Date
    Jan 2009
    Name
    Richard
    State
    NSW
    Location
    2220
    Country
    Australia
    Posts
    228

    Default

    Quote Originally Posted by sundee86 View Post
    Just a question only because u guys didnt mention it.. but after toping up the clutch fluid did u bleed the system from the clutch slave?? if u dont then u will never get rid of the spongy or dead pedal.
    When was the last time u check the clutch resivour? it could have had a slow leak and o'nce the fluid gets low enough it will just suck air into the system
    Though it was the master at first, but it turned out the slave shit itself as well, so I fixed that up too, now I'm all good.

  • #7
    Gone
    Join Date
    Dec 2008
    Name
    Joel
    State
    NSW
    Location
    Picton
    Country
    Australia
    Posts
    4,042

    Default

    the master doesnt have a bleed nipple... hahahah 3 lanes to 1 and u break down in the one lane! hhahaha.. that is gold.. hay i would have given u a push.. what the heck did u do? was it in the middle of the bridge?

  • #8
    Scammer, DO NOT BUY FROM ME!
    Join Date
    Jan 2009
    Name
    Richard
    State
    NSW
    Location
    2220
    Country
    Australia
    Posts
    228

    Default

    I was stuck right at the start of the bridge, the guys doing the maintenance offered to help me push the car, but I just kicked the shit out of the clutch until it popped into 1st gear and drive as far as possible.

    The red lights killed me hard man, so I had to repeat those steps until I got to the Shell servo in South Hurstville so I could buy some fluids to top up with...

    If I ever get into the same situation again, I'm just gonna throw the car off the bridge and hitch a ride...

  • #9
    Member
    Join Date
    Feb 2009
    Name
    Justin
    State
    NSW
    Location
    North Sydney
    Country
    Australia
    Posts
    62

    Default

    Man your fail was truly epic compared to mine

    I jsut abused my t50 and forced it into second to get home

    Cars going to Sprinterman86s tomorrows

    I hope it either the slave the master or a leaking line, please please please

    As the other thing could the be the clutch has jammed shut and thats what has cause the slave to shit its self and dump fluid

    Fingers crossed for not the clutch

  • #10
    Gone
    Join Date
    Dec 2008
    Name
    Joel
    State
    NSW
    Location
    Picton
    Country
    Australia
    Posts
    4,042

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Quote Originally Posted by PeakingDuck View Post
    I was stuck right at the start of the bridge, the guys doing the maintenance offered to help me push the car, but I just kicked the shit out of the clutch until it popped into 1st gear and drive as far as possible.

    The red lights killed me hard man, so I had to repeat those steps until I got to the Shell servo in South Hurstville so I could buy some fluids to top up with...

    If I ever get into the same situation again, I'm just gonna throw the car off the bridge and hitch a ride...

  • Page 1 of 2 1 2 LastLast

    Similar Threads

    1. RX-7 fail.
      By timbo in forum Youtube Chan
      Replies: 3
      Last Post: 2nd November 2010, 11:11 PM
    2. Sale of Fail
      By shift_rook in forum Car Parts For Sale
      Replies: 26
      Last Post: 27th January 2010, 08:03 PM
    3. ADELAIDES ALL JAPAN DAY PICS 56k (if it still exists) will fail fail fail
      By slide86 in forum General Topics (No Technical Questions)
      Replies: 92
      Last Post: 30th April 2009, 02:46 PM
    4. University = fail
      By PuGZoR in forum Offtopic Discussions
      Replies: 42
      Last Post: 24th April 2008, 02:38 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •