Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: dash light issues

  1. #1
    Senior Member trueno85's Avatar
    Join Date
    Dec 2008
    Name
    Ayden
    State
    NSW
    Location
    Silverwater
    Country
    Australia
    Posts
    416

    Default dash light issues


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    wierdest thing happend i turned off my car went to a shop for ten minutes then came back to start it again then i noticed when i was driving that the battery light and rear lights light was still on even though it was fine. Then i realised that when i revved over 3k all of them turned off including the headlights light (it was night) then came back on under 3k. eventually after like 10 minutes they turned off for the rest of the trip even the headlight light

    does anyone have any idea why this would happen? also its a digital dash standard if that helps! no other lights dimmed of anything else affected

  • #2
    Glenn ke_70's Avatar
    Join Date
    Dec 2008
    Name
    Clay
    State
    SA
    Location
    Barossa!
    Country
    Australia
    Posts
    5,318

    Default

    happened 2 me 2 but when i braked they came on

  • #3
    Senior Member 86coupe's Avatar
    Join Date
    Dec 2008
    Name
    Steve
    State
    QLD
    Location
    Cairns
    Country
    Australia
    Posts
    458

    Default

    Whenever I see those lights come on, I turn off every unnecessary electrical item and make a dash for home as I know the alternator has failed and there's not long before the battery runs out, the ecu shuts down and its game over.

  • #4
    Site Supporter Javal's Avatar
    Join Date
    Dec 2008
    Name
    Josho
    State
    VIC
    Location
    Melbourne
    Country
    Australia
    Posts
    2,972

    Default

    Quote Originally Posted by ke_70 View Post
    happened 2 me 2 but when i braked they came on
    Completely different problem. Yours would have been caused by a bad earth on the taillight loom.

    Quote Originally Posted by 86coupe View Post
    Whenever I see those lights come on, I turn off every unnecessary electrical item and make a dash for home as I know the alternator has failed and there's not long before the battery runs out, the ecu shuts down and its game over.
    Agreed with this. Your alternator is not charging. Could be a number of problems with it, but you're probably going to have to replace it.

    First of all though, do the visual inspection - make sure none of the wires have come off the back, and that the battery terminals are done up nice and firmly.
    You can have any brew you want... as long as it's a Datsun / Corolla / What is that?

  • #5
    Senior Member trueno85's Avatar
    Join Date
    Dec 2008
    Name
    Ayden
    State
    NSW
    Location
    Silverwater
    Country
    Australia
    Posts
    416

    Default

    oh really? okay then have to figure out what to do! so even though they turn off again at 3k revs it will be the alternator going?

  • #6
    Senior Member trueno's Avatar
    Join Date
    Dec 2008
    Name
    Nik
    State
    WA
    Location
    North side
    Country
    Australia
    Posts
    143

    Default

    yer alternator is about to go.it happen to me once
    AE86 JDM TRUENO
    FULL JDM EP91 GLANZA V (REPLICA)
    EP82 GT TURBO[SOLD]
    EP91 GLANZA [SOLD]
    AE82 FX GT [SOLD]
    S13 SR20DET SILVIA [SOLD]

  • #7
    Veteran Golberg's Avatar
    Join Date
    Dec 2008
    Name
    Lawrence
    State
    NSW
    Location
    Wollongong
    Country
    Australia
    Posts
    1,339

    Default

    Quote Originally Posted by trueno85 View Post
    oh really? okay then have to figure out what to do! so even though they turn off again at 3k revs it will be the alternator going?
    Think of it this way, at 800 rpm (standard idle) those lights shouldn't be on. So in otherwords at 800rpm the alternator should be charging enough to keep the light off. If the lights stay at anything below 3000rpm it means it having to spin the alternator all the way up to high speed to just scrape enough power to avoid the charge light coming on. So even at 3000rpm its at minimal charge. It'll only get worse, and usually very quickly, alternators quite often just let go in one hit.

    So in all seriousness don't drive the car until you have got the alternator looked at. Otherwise you will almost definitely get stranded somewhere with a flat battery and a non-charging alternator = not going anywhere on its own steam, even with a jump start.

  • #8
    Glenn ke_70's Avatar
    Join Date
    Dec 2008
    Name
    Clay
    State
    SA
    Location
    Barossa!
    Country
    Australia
    Posts
    5,318

    Default

    Quote Originally Posted by Javal View Post
    Completely different problem. Yours would have been caused by a bad earth on the taillight loom.



    Agreed with this. Your alternator is not charging. Could be a number of problems with it, but you're probably going to have to replace it.

    First of all though, do the visual inspection - make sure none of the wires have come off the back, and that the battery terminals are done up nice and firmly.
    wouldnt happen 2 know where the earth is just quick (save me an hour of fuckin round)
    sorry 4 usein ur thread

  • #9
    Veteran Golberg's Avatar
    Join Date
    Dec 2008
    Name
    Lawrence
    State
    NSW
    Location
    Wollongong
    Country
    Australia
    Posts
    1,339

    Default

    Off the top of my head, I think there might be one just under the RHS tail light.

  • #10
    Glenn ke_70's Avatar
    Join Date
    Dec 2008
    Name
    Clay
    State
    SA
    Location
    Barossa!
    Country
    Australia
    Posts
    5,318

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    cheers mate

  • Page 1 of 3 1 2 3 LastLast

    Similar Threads

    1. Electrical issues - Dash, parkers, tail lights not working in Ke70
      By Low Style in forum Technical - Questions
      Replies: 9
      Last Post: 18th April 2013, 05:51 PM
    2. KE70 Electrical Issues (Clock and interior light not working)
      By tanKE70 in forum Technical - Questions
      Replies: 4
      Last Post: 13th June 2012, 04:14 PM
    3. Replies: 1
      Last Post: 29th June 2011, 04:24 PM
    4. Head Light issues
      By Blizzerd in forum Technical - Questions
      Replies: 5
      Last Post: 18th September 2009, 08:07 PM
    5. WTB: Light switch, dash light plug, roof clips
      By li21 in forum Cars or Parts Wanted
      Replies: 0
      Last Post: 18th May 2008, 10:08 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •