Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: 4age ecu ?????

  1. #1
    Senior Member AIROCOBRA's Avatar
    Join Date
    Apr 2009
    Name
    Bob
    State
    ACT
    Location
    Weston
    Country
    Australia
    Posts
    343

    Default 4age ecu ?????


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Hi Guys , I have 2 ecu that are for my 4age AE86 ADM conversion .

    The one that came with the car is 89661-12080 blue label , but on the list of all 4a-g ECU I have it does not appear.
    I have heard that the best ECU to use is 89661-12051 orange label ( on the list as a AE86 JAP 83 TO 87 )

    Now my problem is while the car run ok with the blue one , when I fit the orange one , it starts and runs fine , but engine will not turn off via the key.
    Any one come across this before?????

  • #2
    Senior Member
    Join Date
    Dec 2008
    Name
    Dan
    State
    Vic
    Location
    Western Subs
    Country
    Australia
    Posts
    405

    Default

    im geussing that you (or the previous owner) did the 4age conversion into your 86? it would proly be someting to do with the loom used check all connections and see if theres anything loose
    . h i t o r i k o .

  • #3
    Veteran
    Join Date
    Dec 2008
    Name
    Dave
    State
    QLD
    Location
    Brisbane
    Country
    Australia
    Posts
    2,666

    Default

    Quote Originally Posted by hitoriko View Post
    im geussing that you (or the previous owner) did the 4age conversion into your 86? it would proly be someting to do with the loom used check all connections and see if theres anything loose
    the fact that it runs fine with the blue labeled ecu suggests that all said connections are fine.

    sounds to me that the pin outs might be slightly different between the 2. (though i thought they were interchangeable as well)

    your best bet is to open both ecu's and the pin descriptions are printed on the circuit board. i think your looking for an IGN or a B+ pin that is what is the on/off for the ecu. id cross reference anything that is power related (the smaller plug is power stuff) and see if you can find any differences.

  • #4
    Veteran Nikkojoe's Avatar
    Join Date
    Dec 2008
    Name
    Tom
    State
    WA
    Location
    Perth
    Country
    Australia
    Posts
    2,260

    Default

    They are backwards compatible. The body harness plug pins required for the car to run are in the same position, so it wont matter. It is possible the ecu is faulty. Try swapping with someone else and see if it works.
    1983 AE86 ADM rust spec goodness track car build - end of the road
    1984 AE86 Silver ADM mk2 daily build - SOLD
    1984 AE86 ADM granny car daily now 4AGZE - SOLD
    1983 AE86 ADM Engine Conversion Slut - SOLD
    2002 IS200 6spd - new daily in progress
    1986 AE86 JDM GT-Apex Levin Notchback ready to roll......

  • #5
    Member
    Join Date
    Dec 2008
    Name
    Tigh
    State
    Vic
    Location
    Southside
    Country
    Australia
    Posts
    52

    Default

    Does anyone know if adm ignitor & ignitor driver(if that's what its called) will work with a jdm ecu? Or are all accessories compatible between bigports?

  • #6
    Veteran Nikkojoe's Avatar
    Join Date
    Dec 2008
    Name
    Tom
    State
    WA
    Location
    Perth
    Country
    Australia
    Posts
    2,260

    Default

    You mean igniter and coil? All bigports are the same (exception to 4agze). ADM map sensors are the same, aswell as tps, MAT, water temps etc. All the same....
    1983 AE86 ADM rust spec goodness track car build - end of the road
    1984 AE86 Silver ADM mk2 daily build - SOLD
    1984 AE86 ADM granny car daily now 4AGZE - SOLD
    1983 AE86 ADM Engine Conversion Slut - SOLD
    2002 IS200 6spd - new daily in progress
    1986 AE86 JDM GT-Apex Levin Notchback ready to roll......

  • #7
    Veteran Golberg's Avatar
    Join Date
    Dec 2008
    Name
    Lawrence
    State
    NSW
    Location
    Wollongong
    Country
    Australia
    Posts
    1,339

    Default

    Quote Originally Posted by AIROCOBRA View Post
    orange one , it starts and runs fine , but engine will not turn off via the key.
    Any one come across this before?????
    So wait, if you run the orange label ECU the car keeps running even if you remove the key from the ignition?

    That's totally wacked, it shouldn't even be electrically possible if the loom has been done properly. I'd say either your ECU is majorly messed up or your loom is majorly messed up. I'd personally lean toward the loom, as I wouldn't expect an ECU to screw up and present those symptoms. I would hazard a guess that the slight discrepancies on the pinouts for the ECUs may just be effecting which one works properly. But not because they shouldn't be interchangeable, just random chance with whatever is up with your loom.

  • #8
    Senior Member AIROCOBRA's Avatar
    Join Date
    Apr 2009
    Name
    Bob
    State
    ACT
    Location
    Weston
    Country
    Australia
    Posts
    343

    Default

    As suggested by a kind responder to this dilemma , if I was to find another orange 89661-12061 ECU that I could borrow for a few minutes I would then know if it is a wiring or ECU problem .
    So anyone in Canberra / QBN area who would be prepared to help I would be wrapped.!!!
    Then I could fix problem or send unit back to place of purchase ????
    Only doing this because I am told that I will get a few more revs from the orange unit than from the blue unit. Yes I no an after market unit would be the ants pants , but I am involves in a thing called BUDGET RACING . Ha HA !!!! RACING & BUDGET not words that sit well together i know.

  • #9
    Senior Member Anthony's Avatar
    Join Date
    Nov 2008
    Name
    Anthony
    State
    QLD
    Location
    Brisbane
    Country
    Australia
    Posts
    831

    Default

    The main difference between the two is the BF pin in the 10 pin plug. Id say you have a wiring error somewhere around here in your loom. An error that only the AE86 ECU (orange) can expose. The blue sticker ECU is an aus delivered AE82 twincam ecu btw.

  • #10
    Senior Member
    Join Date
    Dec 2008
    Name
    Dan
    State
    Vic
    Location
    Western Subs
    Country
    Australia
    Posts
    405

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    yeah as i said it would prolly be a loose connector or something
    . h i t o r i k o .

  • Page 1 of 2 1 2 LastLast

    Similar Threads

    1. ADL: 4age loom and ae86 Jap ecu and Aus ecu
      By rke_011 in forum Car Parts For Sale
      Replies: 0
      Last Post: 24th October 2011, 07:14 PM
    2. 4age ECU
      By mr.wikid.sik in forum Technical - Questions
      Replies: 3
      Last Post: 27th August 2010, 08:32 PM
    3. Replies: 15
      Last Post: 22nd December 2009, 05:48 AM
    4. 4age engine, 4age block, ecu, loom, gearbox
      By GZE KE70 in forum Car Parts For Sale
      Replies: 9
      Last Post: 5th March 2008, 10:12 AM
    5. Which ECU for 4AGE?
      By wanabdrifta in forum Technical - Questions
      Replies: 1
      Last Post: 4th July 2005, 06:33 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •