Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: Think i'm gonna sell it...

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Member ONCE-NA's Avatar
    Join Date
    Dec 2008
    Name
    Rod
    State
    VIC
    Location
    Ballarat
    Country
    Australia
    Posts
    58

    Default Think i'm gonna sell it...

    Seriously considering selling this, its been sitting around for ages, basically finished but I cant get it to run properly and im over it.

    Click image for larger version. 

Name:	32546_103241873057167_100001140648009_29118_3129928_n.jpg 
Views:	427 
Size:	70.1 KB 
ID:	23793Click image for larger version. 

Name:	32546_103241879723833_100001140648009_29119_5321189_n.jpg 
Views:	472 
Size:	87.1 KB 
ID:	23794

    Its got a Silvertop 20Valve thats had a rebuild at some stage acording to the previous owner of the motor and some port work was evident when the manifolds were off.
    T-series diff
    Its got the peugeot/corona/Hilux front disk conversion. and Corona rear disks
    8kg front springs and 6 rear
    AGX adjustables all round
    Adjustable rear upper and lower arms.
    all the ball joints and bushes are new.
    16 x 8 Rota Grids with brand new tyres.

    Dunno what its really worth as ive been out of the loop for a few years.
    so i'll put $5000 OBO on it

    If it doesnt sell Ill probably part it out, keep the brakes and wheen and put them back into my TA22 and get that back on the road.
    Last edited by ONCE-NA; 4th January 2012 at 08:12 PM.

  2. #2
    Hair model Jacobxxx's Avatar
    Join Date
    Oct 2009
    Name
    Jacob
    State
    NSW
    Location
    Bangalow
    Country
    Australia
    Posts
    6,966

    Default

    Rego? What Engine? Diff? bit more information would be cool

  3. #3
    Member ONCE-NA's Avatar
    Join Date
    Dec 2008
    Name
    Rod
    State
    VIC
    Location
    Ballarat
    Country
    Australia
    Posts
    58

    Default

    oh yeah, whoops, silvertop 20 valve. and T-series diff.
    Yeah currently registered till august i think

  4. #4
    Member cable tie's Avatar
    Join Date
    Jan 2009
    Name
    shaun
    State
    nsw
    Location
    avalon
    Country
    australia
    Posts
    90

    Default

    by not run properly what do u mean??
    second to a hammer a cable tie can fix anything!!!!

  5. #5
    Senior Member Shitbox's Avatar
    Join Date
    Mar 2010
    Name
    Raymond
    State
    VIC
    Location
    Western Suburbs
    Country
    Australia
    Posts
    166

    Default

    also interested in what the problem is with it running right.
    and would you sell cheaper with standard wheels.
    83' KE70 4AGE'D
    84' AE71 4AG Twin 45 DCOE webers

  6. #6
    Member ONCE-NA's Avatar
    Join Date
    Dec 2008
    Name
    Rod
    State
    VIC
    Location
    Ballarat
    Country
    Australia
    Posts
    58

    Default

    maybe a bit cheaper with standard wheels, you'd want to put something pretty wide on there though, the rear guards are PUMPED!

  7. #7
    Member ONCE-NA's Avatar
    Join Date
    Dec 2008
    Name
    Rod
    State
    VIC
    Location
    Ballarat
    Country
    Australia
    Posts
    58

    Default

    its running really rich, idles and runs pretty rough, keeps fouling the plugs. The caps in the ecu have been replaced as it died like straight after i got it running after i put the motor in. I hadnt even attempted to drive it or anything as the exhaust and diff etc werent in.
    Maybe there is something else wrong with the ecu as it did run nicely for those few seconds before it died.

  8. #8
    Senior Member Dori_Dori's Avatar
    Join Date
    Dec 2008
    Name
    Andy
    State
    VIC
    Location
    Westside
    Country
    Australia
    Posts
    176

    Default

    pm'd you

  9. #9
    Senior Member
    Join Date
    Jun 2011
    Name
    bazz
    State
    nsw
    Location
    sydney
    Country
    australia
    Posts
    213

    Default

    any rust?

  10. #10
    Member ONCE-NA's Avatar
    Join Date
    Dec 2008
    Name
    Rod
    State
    VIC
    Location
    Ballarat
    Country
    Australia
    Posts
    58

    Default

    To everyone who has messaged me, i'm really busy at the moment, I'll try get some more photo's soon. I'm also trying to get hold of another ecu to try get it running better as i suspect it may still be the problem.

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. When you gonna let me tap that
    By MeZ Prod in forum Epic Threads
    Replies: 370
    Last Post: 1st October 2012, 03:55 PM
  2. Replies: 27
    Last Post: 20th April 2009, 08:47 PM
  3. im gonna regret this
    By jdm_dreamr in forum Toyotas in the Media
    Replies: 4
    Last Post: 5th September 2006, 07:40 PM
  4. DADDY'S ARE GONNA BE MAD!
    By sherlock in forum Offtopic Discussions
    Replies: 29
    Last Post: 11th November 2005, 06:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •