Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: Rod's filthy ADM beater

  1. #1
    Junior Member -rod-'s Avatar
    Join Date
    Apr 2009
    Name
    Rod
    State
    Queensland
    Location
    Bris
    Country
    Australia
    Posts
    22

    Default Rod's filthy ADM beater


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Howdy lads,

    Thought it was about time I did one of these to introduce myself.

    Rod from Westside Bris
    I bought this Sprinter a year ago to run as a daily:









    It broke down a couple times and I realised the Alternator was screwed, so I replaced it with a Delco. The battery and ignitor also died and I replaced those..also changed leads, plugs, gbox and engine oils, water and pump.
    The fuel filter mount was fudged so I got an inline one from a R32 put in.
    The exhaust was also sh*t and I bought a ridiculously loud one off 70xins old setup hahah, so much better.

    The primer and bog job was the dodgiest Ive ever seen so I had it painted around September and now it looks like this:


    A week after paint I was defected and had to go to PITs. That was a dark period of my life. :|
    Had to get new parkers, seat mounts welded, quiet muffler, etc etc. So much stuff, it was seriously crap.
    Anyway, hopefully smooth sailing from now on, will update with a few more details later, gf is bugging me.

    Will leave you with this pic with my buddy's immaculate E30:


    Thanks for reading!

  • #2
    Veteran Jimmee1990's Avatar
    Join Date
    Mar 2011
    Name
    James
    State
    VIC
    Location
    Mt Dandenong
    Country
    Australia
    Posts
    1,127

    Default

    Looks like a nice job on the paint from the photo's, what happened to the mk3's? Welcome to the forum man

  • #3
    Noooob
    Join Date
    Jun 2010
    Name
    Matt
    State
    NSW
    Location
    Campbelltown
    Country
    Australia
    Posts
    5,186

    Default

    Thats a huge transformation from when you originally got it...
    Ae86 Drivingclub - Toyota AE86 Car Club where AE86 | KE70 | Toyota 86 / GT86 | Subaru BRZ | Scion FRS owners

  • #4
    Moderator dove grey 64's Avatar
    Join Date
    Aug 2010
    Name
    Geoff
    State
    VIC
    Location
    mt dandenong
    Country
    Australia
    Posts
    2,444

    Default

    Quote Originally Posted by Jimmee1990 View Post
    Looks like a nice job on the paint from the photo's, what happened to the mk3's? Welcome to the forum man
    i was thinking the same about the mk3's, good work, looks 100 times better then when you got it

  • #5
    Junior Member -rod-'s Avatar
    Join Date
    Apr 2009
    Name
    Rod
    State
    Queensland
    Location
    Bris
    Country
    Australia
    Posts
    22

    Default

    Thanks guys, I didn't originally plan on painting it for ages, but a friend of a friend gave me a good price and I was terrified of rust. Couldn't be happier.

    Sadly one of the mk3s has a busted lip from a prior accident and I don't know if it holds air that well. They're out of action til I can take it to depulu.

  • #6
    Junior Member -rod-'s Avatar
    Join Date
    Apr 2009
    Name
    Rod
    State
    Queensland
    Location
    Bris
    Country
    Australia
    Posts
    22

    Default

    Pics of the MK3 damage:





    Got an alright quote from Depulu, just have to find an excuse to get down the coast.

  • #7
    Junior Member -rod-'s Avatar
    Join Date
    Apr 2009
    Name
    Rod
    State
    Queensland
    Location
    Bris
    Country
    Australia
    Posts
    22

    Default

    I painted the cam covers over the weekend, so much more effort than I was expecting.

    Before:





    After:






    In hindsight, paint stripper is crap. When I do it again I will get them blasted or something. That shit took hours.
    Also the vasoline on the lettering method is ghetto, definitely use masking tape. Note how shitty the "Twin" looks. Oh well!!

  • #8
    Junior Member -rod-'s Avatar
    Join Date
    Apr 2009
    Name
    Rod
    State
    Queensland
    Location
    Bris
    Country
    Australia
    Posts
    22

    Default

    I started hearing the worst noise from the rear end on a highway drive last weekend.
    Sort of like a really harsh banging when on power above 30km/h which would increase with wheel speed.
    I took it into Steve at Diff and gearbox Industries who is a top bloke, no bs, super friendly.

    This is what had happened:







    Thankfully I sourced some new bits pretty quickly and she should be back together for the weekend.
    I will be going from a 4.3:1 to 3.7:1. I think acceleration will suffer but I wont be sitting on 3500rpm on the highway.

  • #9
    Veteran timbo's Avatar
    Join Date
    Aug 2009
    Name
    Tim?
    State
    QLD
    Location
    Wild West
    Country
    Australia
    Posts
    2,141

    Default

    Haha, try a T40 with 4.3's!

    Isn't there a Depulu place at Darra?

  • #10
    Veteran LittleRedSpirit's Avatar
    Join Date
    Dec 2008
    Name
    Matt
    State
    QLD
    Location
    West
    Country
    Australia
    Posts
    1,899

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    I had a similar failure on some 4.3 T gears where I lost 2 teeth from the pinion aswell just like that.

    It was on a long highway trip. I think they went at highway speed and I just got a grinding tone from the diff.






  • Page 1 of 2 1 2 LastLast

    Similar Threads

    1. filthy doser
      By ae71 in forum Dirty Dattos
      Replies: 113
      Last Post: 4th December 2010, 05:15 PM
    2. HilToNs filthy blue shitter. new video's up of shitpan.
      By HiLtOn in forum KE70 / AE71 Owners Forums
      Replies: 694
      Last Post: 12th February 2008, 05:37 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •