Results 1 to 5 of 5

Thread: need some advice on installing 20v itbs on 16v 4age bigport

  1. #1
    Junior Member
    Join Date
    Feb 2013
    Name
    simon
    State
    wa
    Location
    queens park
    Country
    australia
    Posts
    1

    Default need some advice on installing 20v itbs on 16v 4age bigport


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    ok guys im currently building my ae71 road/drift car i have a 16 valve b igport 4age which im fully rebuilding at the moment i want to run it on 20v throttle bodies just need some help on choosing my wiring harness? (bigport/smallport) and what else is involved i have seen this done on a ke70 before and he was also running the standard ecu can someone help me please ....will upload pics of the build soon :/ thanks

  • #2
    Wheel Whore JDMWheels's Avatar
    Join Date
    Sep 2010
    Name
    Daniel
    State
    NSW
    Location
    Sydney North
    Country
    Australia
    Posts
    302

    Default

    You will need to run aftermarket Engine Management AFAIK - I have a few sets of AE111 20V Throttle Bodies for sale if you need some.

  • #3
    Noooob
    Join Date
    Jun 2010
    Name
    Matt
    State
    NSW
    Location
    Campbelltown
    Country
    Australia
    Posts
    5,205

    Default

    It'll run on the stock ecu if you wire the tps in reverse. But to get the most outta it an aftermarket ecu is recommended.

    Could be worth going a 20v?
    Ae86 Drivingclub - Toyota AE86 Car Club where AE86 | KE70 | Toyota 86 / GT86 | Subaru BRZ | Scion FRS owners

  • #4
    Veteran Rice86's Avatar
    Join Date
    Jan 2009
    Name
    Richard
    State
    NSW
    Location
    Liverpool
    Country
    Australia
    Posts
    1,853

    Default

    well if you haven't already bought the ITB setup, i have the T3 adopter for bigport + 20v ST ITBs and TPS + 70mm velocity stacks for sale, $700 posted to your door!! cheaper then chips and gravy
    dose

  • #5
    Veteran lolwat's Avatar
    Join Date
    Oct 2009
    Name
    Michael
    State
    NSW
    Location
    Crimebrook 2749
    Country
    Australia
    Posts
    3,974

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    What ecu are you running?(bigport or smallport) what dissy do you have,
    jsut stay with what you had with the wiring harness

    this a for WTB thread?

  • Similar Threads

    1. 16v bigport v 20v? Carbs v itb's?
      By BMXB in forum Technical - Questions
      Replies: 100
      Last Post: 17th August 2012, 08:23 AM
    2. Replies: 11
      Last Post: 12th February 2012, 03:57 PM
    3. 20V Quads to 16V Bigport > Induction / Plenum Box
      By GeeEss in forum Technical - Questions
      Replies: 21
      Last Post: 31st August 2011, 05:47 PM
    4. st itbs to 16v bigport whats needed
      By sideburns in forum Technical - Questions
      Replies: 3
      Last Post: 7th August 2010, 05:39 PM
    5. Installing a W58 into my AE86 - Any advice/info/tips???
      By Maxhag in forum Technical - Questions
      Replies: 12
      Last Post: 9th April 2008, 10:51 PM

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •