Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 37

Thread: Westfield SEiW Clubman

  1. #11
    Veteran AJPS's Avatar
    Join Date
    Nov 2008
    Name
    David
    State
    SA
    Location
    Lonsdale
    Country
    Australia
    Posts
    4,246

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    good stuff...
    - 10 year anniversary Tshirts http://www.ae86drivingclub.com.au/fo...irts-group-buy -

    Garage sale http://www.ae86drivingclub.com.au/fo...3-autumn-sales Specials on front end kits - pm me


  • #12
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default

    Mounted the new headlights on the car tonight. Massive improvement I reckon! For the time being I have just used some washers as spacers in the bracket, but it works. Eventually I'll get a better, nicer solution made, but this is a good start. If I don't go out to a rig tomorrow I'll head round to a mates place and we'll wire them up. I think these look heaps better than the big, ugly old ones that were on it.







    Might finally be getting a better ECU for it in a couple of months. Depends on if our broker gives us the all good regarding our current mortgage application, but if it goes ahead it will be much better than the useless POS it has now.

  • #13
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default

    New headlights are wired up. There was drama with this! Drove to my mates place for some help as he knows his stuff with wiring. It took much longer than expected, much to my wifes dismay as I was meant to take her out for dinner to celebrate getting unconditional approval to buy our first home. Steve and I got the drivers side wired in and working. We then set about doing the passengers side. Had to extend the wiring from the plug as they don't supply it with enough wire sticking out the back. Did this, plugged it in and tested. Passenger side worked but drivers side no longer did... I was not happy as it had taken about 3.5 hours to get to his stage. Gave up and told Steve I'd have a look at home another day. Jumped in to drive home and it wouldn't start!! Had to leave it there and take one of his cars home.

    Head over there one afternoon a week or so later. The problem was a shit fuse for the fuel pump. It wasn't blown, and at first glance looked fine. However on closer inspection it was broken on one side where the "bridge" part joins the "prongs". Only noticed because I must have moved it the right way accidentally while looking. Replaced that one and turned ignition on and fuel pump primed straight away. I thought to myself I bet this will start. And sure enough it did!

    We then had another look at the drivers side headlight. Turns out that one of the earth wires had broken off at the crimp I did. Fixed that and all good. So now I can start driving it again

  • #14
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default

    Damn thing broke again. This time it is a little more serious than a dodgy fuse. Today I was pulling out on to the highway and gave it some beans. Changed in to second gear and when I released the clutch something went bang... Literally. Then the car wouldn't drive. I pulled over to try and check some things out. What it was doing is this. I put it in first and let the clutch out and it would move slowly, but when I gave it some accelerator all that happened was the engine rev'd freely and the car didn't move forward any faster. We turned the car off, put it in first gear and started the car with no clutch. It started, and started driving very slowly.

    Something not good in the clutch. It's at a mate's place in his shed now, and he'll be back from work in a couple of days. We'll pull it apart and have a look. Thinking whether or not now is a good time to get a light flywheel to put on it, or if I should just fix this problem.

  • #15
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default

    So it turns out the problem isn't the clutch. It is this.



    Bigger problem is that Arrow no longer sell replacement uni joint drive shafts or have the uni joints made any more. They sell replacement CV shafts, but these are $560 each and I can't afford that right now. Luckily the QLD dealer/rep for Arrow cars had a spare uni or 2 in his shed, and I got in contact with an engineer who loves clubbies and does a lot of work on them, to fix my axle. I'll give him a call tomorrow and see if he has made progress, but hopefully it will be back up and running on my next break.

    I have put a deposit on, and will pay the balance shortly, for a few things. A lightweight flywheel, that also comes with a clutch that needs a rebuild, and a replacement VDO speedo and tacho. The current speedo doesn't work, and the tacho doesn't match the rest of the gauges, so at the price I got this pair I couldn't say no.

    Then it is time to think about either paint or starting to collect parts for the engine build.

  • #16
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default

    Picked up the repaired driveshaft a couple of days and put it back in the car this arve. Good as gold

  • #17
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default

    Have taken the car for a couple of good drives since putting in the driveshaft and it is going well. Going to be entering Pittsworth Street Sprints this week, and hopefully doing a WCC day at Lakeside next month.

  • #18
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default

    Ready to get the R888Rs fitted


  • #19
    Senior Member
    Join Date
    Nov 2009
    Name
    Matt
    State
    QLD
    Location
    Flaxton
    Country
    Australia
    Posts
    133

    Default

    lol going to do the dakar....

  • #20
    Member
    Join Date
    Jun 2014
    Name
    Bren
    State
    Queensland
    Location
    Centenary Heights
    Country
    Australia
    Posts
    55

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Haha, looks that way! Tyres fitted and wheel alignment done. All ready for Lakeside on the 19th of July, and Pittsworth Sprints in September. Can't wait

  • Page 2 of 4 FirstFirst 1 2 3 4 LastLast

    Similar Threads

    1. Engine warning light on in my clubman
      By london67 in forum Technical - Questions
      Replies: 1
      Last Post: 1st June 2013, 06:12 AM
    2. Blacktop starter motor on Westfield
      By Westie20v in forum Technical - Questions
      Replies: 8
      Last Post: 22nd November 2012, 10:16 AM
    3. 1975 Mini Clubman
      By blake12345 in forum Cars for Sale (Not Toyotas)
      Replies: 12
      Last Post: 15th March 2011, 09:00 PM
    4. 1974 Mini Clubman - Sydney
      By Beau in forum Cars for Sale (Not Toyotas)
      Replies: 29
      Last Post: 31st August 2009, 08:44 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •