Results 1 to 3 of 3

Thread: 4A-GE 20v Silvertop low idle prob.

  1. #1
    Junior Member
    Join Date
    Oct 2017
    Name
    Alex
    State
    Moca
    Location
    Ortega
    Country
    Dominican Republic
    Posts
    6

    Default 4A-GE 20v Silvertop low idle prob.


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    So Iím a new member, I have a AE85 coupť with a 4age 20v silvertop transplant. Currently having some troubles with idling. It will drop so low it starts to lope and sometimes it stalls. Can this be a vac. leak or could it be carbon build up on my itbís. Its pretty much stock, Just running straight pipe. Also I would like to add i believe itís running rich because the gassy smell is horrendous. Makes my eyes burn if Iím not going at decent speed lol
    Last edited by AlexFourTwenty; 14th October 2017 at 06:21 PM. Reason: Title edit

  • #2
    Veteran LittleRedSpirit's Avatar
    Join Date
    Dec 2008
    Name
    Matt
    State
    QLD
    Location
    West
    Country
    Australia
    Posts
    1,927

    Default

    If you tell us enough to help that would be a start.

    What ecu? How well tuned? Vac leaks lead to high idle, not low, so your problem is too little air or too little fuel or both. Being that you think its rich, and it runs, id say air is your culprit. What are you doing for idle control? On a silver top I used to just run a 12mm hardie pope plumbing tap to adjust the idle air feed connected to the stock vacuum array on the top of the manifold with a little breather on the end.

    Itbs are easy to clean and remove. It takes a lot of flushing to clean out all the mini air ports on them and the manifold. Helps to remove the top piece of the vac manifold.

    There are a series of adjustable ports on the itbs that bypass air, accessible by a bleed screw needle valves in the face of the throttle near where the trumpets mount. Use those to sync the vacuum on each port once you have your idle good, and the whole motor gets smoother. You need vacuum sync gauges to do this.

    If you have an aftermarket computer you can adjust fuelling manually. If you have stock ecu and too much fuel, then you might have too much fuel pressure, a dodgy reg maybe or leaking injectors. Its a good idea to clean the injectors on a 4age before running it.






  • #3
    Junior Member
    Join Date
    Oct 2017
    Name
    Alex
    State
    Moca
    Location
    Ortega
    Country
    Dominican Republic
    Posts
    6

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Hey @littleredspirit I just found out it was actually my throttle cable that needed adjusting. Still running a bit rich, I believe it has a stop st ecu but I think they might have messed with the maf internals.

  • Similar Threads

    1. [WA] silvertop 20v
      By Adsport in forum Car Parts For Sale
      Replies: 2
      Last Post: 31st May 2013, 10:42 PM
    2. 16v itb from silvertop
      By DRFTPG in forum Technical - Questions
      Replies: 2
      Last Post: 23rd October 2010, 09:18 AM
    3. Replies: 23
      Last Post: 4th October 2009, 10:23 PM
    4. Silvertop 20V $600!!!!!!
      By KonaKid in forum Car Parts For Sale
      Replies: 44
      Last Post: 22nd June 2008, 12:25 PM
    5. silvertop 20v
      By spoon in forum Car Parts For Sale
      Replies: 6
      Last Post: 19th April 2008, 05:07 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •