Results 1 to 6 of 6

Thread: MAF sensor question

  1. #1
    Member
    Join Date
    Feb 2018
    Name
    EDWARD
    State
    FL
    Location
    SUNRISE
    Country
    United States
    Posts
    60

    Default MAF sensor question


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    My KP61 starlet with a 4A-GE engine project has been stalled since I began to work on the interior. Yesterday, when I went to start and move the car, it refused to idle, but it would rev up. Just not running very well, period.
    I noticed that the "door" on the MAF sensor was hanging open. Not closing. In fact, the door stays anywhere I pushed it with my finger. Am I correct that the door is on a small spring and that manifold vacuum opens it? Then the door closes at little to no throttle?
    Mine just sits there and allows a loud vacuum hissing noise.
    Time for a rebuilt MAF?
    Last edited by ZEROPILOT; 27th March 2018 at 12:09 AM. Reason: correction in grammar

  • #2
    Senior Member Hen may possibly be a nut's Avatar
    Join Date
    Jan 2009
    Name
    Hen
    State
    Victoria
    Location
    Mt Macedon
    Country
    Australia
    Posts
    904

    Default

    Yes, it works as you describe. More airflow into engine means the door opens more. It should spring closed when the engine is off.

    You might be able to clean it out and get it working again.

  • #3
    Member
    Join Date
    Jan 2015
    Name
    Dave
    State
    Michigan
    Location
    South Lyon
    Country
    USA
    Posts
    45

    Default

    Yupper, You have a problem!!! It's probably going to be easier to find a used MAF then a replacement part. I would disassembly the MAF, to see if it is some thing you can fit, but I would not hold your breath. I would think you need the an "identical" spring as a replacement. Davew7

  • #4
    Member
    Join Date
    Feb 2018
    Name
    EDWARD
    State
    FL
    Location
    SUNRISE
    Country
    United States
    Posts
    60

    Default

    Cool.
    Thanks so much.
    I found a rebuilt online.
    MUCH easier to find than a lot of other parts!

  • #5
    Member
    Join Date
    Feb 2018
    Name
    EDWARD
    State
    FL
    Location
    SUNRISE
    Country
    United States
    Posts
    60

    Default

    I tried that.
    After cleaning it's still limp like a wet noodle.
    It lasted some 30 odd years.
    Not a bad run.

  • #6
    Member
    Join Date
    Feb 2018
    Name
    EDWARD
    State
    FL
    Location
    SUNRISE
    Country
    United States
    Posts
    60

    Default


    TO REMOVE ADS, PLEASE
    REGISTER OR SIGN IN
    Click image for larger version. 

Name:	20180329_153548-1.jpg 
Views:	10 
Size:	277.0 KB 
ID:	37828Found one online!
    A $200 rebuilt.
    It's good now.

  • Similar Threads

    1. O2 sensor question
      By haveaparty in forum Technical - Questions
      Replies: 10
      Last Post: 2nd November 2012, 09:15 PM
    2. Question regarding Intake Air Temperature Sensor (IAT)
      By mikare in forum Technical - Questions
      Replies: 10
      Last Post: 19th June 2010, 08:10 AM
    3. 4age flywheel & sensor question
      By keimeier in forum Technical - Questions
      Replies: 8
      Last Post: 18th April 2010, 08:50 PM
    4. sensor question.
      By hugh in forum Technical - Questions
      Replies: 7
      Last Post: 5th December 2007, 07:43 PM
    5. wtb 4AGE Map sensor and throttle sensor
      By ae86driftstyle in forum Cars or Parts Wanted
      Replies: 3
      Last Post: 22nd March 2007, 08:35 PM

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •